Creating HTML documents
in Adobe’ PageMaker 6.5
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So why would you use PageMaker to produce content for the Web?
Here are two reasons: To convert existing publications into Web-

appropriate content quickly and to easily take multiple-column

PLEASE NOTE: These tips layouts and export them as HTML tables— both without writing a
work equally well on
Windows® or Macintosh® word of HTML code. In PageMaker 6.5 the revamped HTML Export

platforms. Keyboard
shortcuts are noted for both
platforms: the Command
key on the Macintosh maps

plug-in automatically converts graphics to GIF or JPEG files and

allows you to map text styles to HTML styles. But its coolest new

to the Windows Control key, feature is the ability to preserve the layout of your pages and export
and the Option key maps to
the ALT key. them as HTML tables. There’s a world of difference between 6.0 and

6.5 when it comes to exporting to HTML and making links. This tip

"‘ will go over the basics of exporting pages to HTML. For a thorough

Adobe set of tips about creating links, check out Hyperlink-o-rama.
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CREATING PAGE-TO-PAGE LINKS
with Adobe PageMaker 6.5
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To create successful Web designs, it helps to have a basic understanding of
the current design limitations in HTML. Keep your designs simple and keep
images small (file-size-wise, that is). Work with your Internet service pro-
vider or your company’s Webmaster so that the files you provide are clean
and consistent with their conventions. These production tips will help
ensure quality and efficiency in your HTML work with PageMaker 6.5.

GETTING STARTED WITH HTML IN PAGEMAKER

1. Before you save and export
Web pages, set up a folder
hierarchy and file-naming
convention. Check with your
Webmaster or Web service
provider for advice about an
appropriate hierarchy of
folders for your Web pages.
Maintain that structure
absolutely as you create your
files and when you post them
to your Web Server.
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Site structure

Try to keep your direc-
tory structure flat. For
example: <SiteName>
folder/section1/ images.
Your file names should
contain no spaces or
special characters. If you
must have a space, use
an underscore instead.
PageMaker 6.5 will auto-
matically append .gif or
jpeg/.jpg to the image’s
file name when it ex-
ports to HTML.

2. Customize your copy of
PageMaker 6.5 with Web-
friendly defaults. With no
documents open, choose
File>Preferences>Online.
Then, deselect Center Upper-
left of Anchor When Testing
Hyperlinks in the Hyperlinks
section, and identify the Web
Browser with which you’ll

Online Preferences

l 0K l

Cancel

r Huperlink
[< Outline link sources when hand tool is selected
[JCenter upper-left of anchor when testing hyperlinks
r UEL inferrnation
Proxies: Port: |3|] |
No proxies:

to folder:

Download macintosh:Desktop...older:WebSource

 web browser

HTML Import

Not only can you ex-
port HTML and their
associated linked files
with PageMaker 6.5,
you can also import
HTML a variety of
ways. To specify the
folder into which these
files get copied on
your hard disk, click
Browse in the Down-

. Netscape Navigator™ 3.0
view your HTML pages by load to Folder option
clicking the Browse button in of Online Preferences.
the Web browser section.
3. The measurement system —————— it
of choice for the Web is Measurements in: [ o ]
pixels. To simulate pixel Uertical ruler: [ points
measurements in PageMaker, Layout problems: [] Show loose/tight lines
. . []Show “keeps” violations
use picas and points. Choose Graphics display: O Gray out
File>Preferences>General to @ standard

set picas as your measure-
ment unit. Then, when you
type Opxx, anything that
follows the p will be in points
or pixels.

) High resolution

Control palette
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It really helps to know enough about HTML standards to predict what layout and design
techniques can be accurately reproduced in HTML. For example, if you want nonstandard display
fonts, you should convert the text into a graphic. You should also avoid overlapping objects. If you
have overlapping elements, group them and convert them to a graphic. As we gather more

conversion tips, we’ll share them with you in future Tip & Technique documents.

CREATING A NEW HTML DOCUMENT

1. Choose File>New, and then
select one of the new Web

Document Setup

Cx)

Relative page sizes
The preset Browser

page sizes: Browser-large or Page size: ‘/tiuae,r Lancel pages equal one
Browser-small. These two Dimensions: Taglmd window’s worth of
) w all. w orientation: | R4 content. Many HTML
sizes represent the most Options: :: out pages are longer.To
common image areas for Web BS pge num design with scrolling
pages. Ask your Webmaster N ot s Browser - small ] in mind, try editing
what the standard page width e Browser - large | O the page dimen-
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HTML Styles from the Styles
palette pop-up menu. These
styles help you specify type
that looks roughly like
HTML-styled serif text.
Bulleted and numbered lists
do not display in PageMaker
exactly as they will in HTML.
To check their final appear-
ance, export to HTML and
view them in a browser.
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HTML styles are applied,
you can use the Story
Editor. Click on text and
choose Edit>Edit Story.
Select View Style Names
on the Story menu. If
you see a bullet rather
than a style name, then
the adjacent paragraph
has no style applied;
click an insertion point
in the paragraph, and
apply a style.

3. PageMaker 6.5 has a special
color library for Web docu-
ments. Use it to specify the
color of text or page back-
ground. Since PageMaker’s
Paper color acts as a back-
ground color, you can define
the background color for your
HTML pages by editing Paper
in the Colors palette. Double-
click Paper, and choose
Libraries: Online. Then
choose a swatch and click OK.

Color Options

Name: Paper

Type:
Model:

[ overprint
Red:

Green:

Blue:

CMS Info

(T
CMS Source...
Libraries: Izl
Crayon
DIC COLOR GUIDE SPOT
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Greys
255

MUNSELL® Book of Color

MUNSELL® High Chroma Colors

CMS is currently off. This color uses: Mone.

PANTONE ProSim EURD®
PANTONE® Coated
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w

Online colors library
The colors in the
Online colors library
will display consistently
in Macintosh and Win-
dows browsers and will
not dither. This is the
same set of 216 colors
as the Web palette in
the Indexed color mode
in Photoshop® 4.0 or
the Browser-safe colors
in Adobe Illustrator®.



You have several options for how you convert your PageMaker pages into HTML files. You can:
(1) Export pages to standard HTML.(Text will flow in a linear fashion and graphics will appear
in the text in the order they appear on the page.)(2) Export stories. (This option works best when
you want to reorder the stories and when graphics are placed in-line with the text.)(3) Export
pages that preserve the layout. (PageMaker uses HTML tables to position elements as accurately
as possible on the HTML page.)

EXPORTING PAGES TO HTML

1. Choose File>Export>
HTML. If you have a long
document with lots of styles,
it may take awhile to analyze
it and display the Export
HTML dialog box. Click New
to give your document a title
that will appear in the title
bar for that page and click
on the pages you want in
Unassigned then click Add to
select the pages that make up
this particular HTML file.

Exdport HTML: New Contents

Document Title:

Step 2: Page to page links

Cancel

@ Assign PageMaker Pages
) Assign Stories
Unassigned
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Assigned To Document

Background... ## No background graphic is chosen %%

Create many HTML
files from one
document

You can break up your
PageMaker document
into multiple HTML
files. For example, you
can export a title page
and table of contents
as a home page and
the remaining pages
as other HTML pages
that link to the home

page.

2. You can also add a back-
ground pattern here. Click
Done. Now choose the
location to which you’ll
export your HTML files by
clicking Document. Name
your file with the .html/.htm
extension. To create a new
folder for your HTML files
and images, click New to
create a new folder and then
name the file and click OK.
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File Name For HTML Document:
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[]Sawe images into this folder
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[ Cancel ] [ Done ]
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Desktop -
Options...
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Background pattern
To assign a background
pattern to your page,
just click the Back-
ground button when
you create a new HTML
document. Locate the
GIF file you'll use for
your background. Your
background GIF should
be in the GIFs/Images
folder for your site.

3. By default, all of the images
associated with the file are
copied into the folder you
selected for the HTML
document. If you want
images saved in a separate
folder, deselect Save images
into this folder in the Docu-
ment location for saving
dialog, and click OK. Then
click Graphics, and select the
appropriate folder for the
images.
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Lines but no boxes,
ovals, or polygons
PageMaker-drawn
horizontal lines will be
converted to horizon-
tal rules (<HR>) on the
HTML pages. But
boxes, ovals, or poly-
gons must be con-
verted into a graphic
to export successfully
into HTML.



You can do a one-step export from a print document to a Web document and convert TIFE,

PICT and EPS graphics easily to Web image formats. PageMaker exports them in their original
(usually large) color depth. Since images on the Web should be as small as possible, to try to
reduce their file size before you export your final web page. So here’s my recommendation: Do one
export, tweak your design, and check out the file sizes for the GIFs and JPEGs that were exported.
Then select the large images and reexport them with more control using Export graphic in
PageMaker, or use Photoshop to reduce their file size and relink them.

EXPORTING PAGES TO HTML (continued)

4. Now click Options. In the
Options dialog box, you can
set whether your pages will
be exported to HTML tables
or not, map styles, and de-
fine how graphics are con-
verted to a Web-friendly
format. To export documents
with the basic layout pre-
served, check Approximate
Layout Using HTML Tables
When Exporting Pages.

Export HTML |

Options ——8—~————|

[ Approximate layout using HTML tables when exporting pages

Exported page width: pixels
rStyle Assignrnents
PageMaker Style HTML Style L« ]
[Ma style] Eody Text 3] @
Body text Body Text [0}
Caption Heading & ®
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Headline Heading 1 ®
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[ Preserve character attributes

r Graphics

Export as: ® All to GIF

Al to JPEG

File Names: ) Use Long Names
@ Use Short Names (8.3)

Exported page
width

The pixel dimension
that displays in the
edit box is your cur-
rent page width. You
may choose from one
of the preset page
widths in the drop-
down menu or type in
a new value. All of the
elements on the page
will be scaled appro-
priately depending on
the width you choose.

5. If you've applied paragraph
styles to your text, you can
map PageMaker styles to
standard HTML Styles here.
If you’ve already assigned
HTML styles from the Styles
palette, no mapping of styles
is necessary. PageMaker will
pass along local character-
level text formatting, such as
bold, italic, and text color if
you check Preserve Character
Attributes.

Export HTML |
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Exported page width: pixels
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Body text

Captian

Caption head

Heading
Heading 5 j

Heading 6

Body Text

Headline

Heading 1 Address

Intro

Body Text Blockquote

Callout

Heading & Menu List

Cover
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[ Preserve character attributes

Unordered List
Directory List

r Graphics
Export as: ® All to GIF
ANl to JPEG

Definition List
File Names: ) U|

[} Um:‘

Preformatted

Regular HTML

If your document is
only one column with
a few graphics or the
graphics are placed
in-line with the text,
deselect the Approxi-
mate Layout Using
HTML Tables option to
generate regular
HTML output.

6. When you export HTML,
all of the images in your file
will convert to GIF or JPEG
format and be saved into the
folder you've identified for
images. You'll want to down-

sample them to 72 dpi as well.

If you already have GIFs &
JPEGs placed in your docu-
ment and saved in the proper
folder, deselect Downsample
to 72 dpi, so PageMaker only
creates the HTML file.
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II™® New Anchor...
2 Delete “Nightlif
' New Source...

Gr aphics

Export as: @ All to GIF
ANl to JPEG

) PageMaker chooses

File Names: ) Use Long Names
@ Use Short Names (8.3)
] Downsample to 72 dpi

GIFs, JPEGs and
color settings

The PageMaker
Chooses option con-
verts full color-images
to JPEGs and indexed-
color or grayscale
images to GIFs.
PageMaker applies the
Netscape color palette
and interlacing to im-
ages exported to GIF.
Images exported to
JPEG use a Medium
compression setting.



EXPORTING PAGES TO HTML (continued)

7. After you export the file, if
you have View HTML checked
in HTML Export, the HTML
tile opens in the browser you
specified in the Online
Preferences dialog box. You
can then proof your work, and
test your links. If necessary,
make corrections to your
PageMaker file, and reexport
it. Or, if you know HTML, you
can open the file in an HTML
editor to modify it.

e

Netscape: Page-to-Page Links with Adobe PageMaker 6.5
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CREATING PAGE-TO-PAGE LINKS
with Adobe PageMaker 6.5

Step 1

Create the destination for your link
on & page in your Pagehdaker
CULTLEIT.

1. et the destination or "anchor” for
wour link by selecting a range of text
or a graphic on a page.

Delete *
New Sou

B2

Export HTML

Cancel

[ View HTML
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